◎安裝webmin

root@www3:~# sudo apt-get install libauthen-pam-perl libnet-ssleay-perl libpam-runtime openssl perl perl-modules
root@www3:~# sudo apt-get -f install
root@www3:~# wget http://prdownloads.sourceforge.net/webadmin/webmin_1.570_all.deb
root@www3:~# sudo dpkg -i webmin_1.570_all.deb
root@www3:~# sudo apt-get install libio-pty-perl

 

1.安裝套件

root@www3:~# sudo apt-get install libauthen-pam-perl libnet-ssleay-perl libpam-runtime openssl perl perl-modules

正在讀取套件清單… 完成
正在重建相依關係
正在讀取狀態資料… 完成
openssl 已經是最新版本了。
perl 已經是最新版本了。
perl-modules 已經是最新版本了。
下列【新】套件將會被安裝:
libauthen-pam-perl libnet-ssleay-perl
下列套件將會被升級:
libpam-runtime
升級 1 個,新安裝 2 個,移除 0 個,有 57 個未被升級。
需要下載 359kB 的套件檔。
此操作完成之後,會多佔用 1,135kB 的磁碟空間。
下載:1 http://tw.archive.ubuntu.com/ubuntu/ lucid-updates/main libpam-runtime 1.1.1-2ubuntu5.4 [116kB]
下載:2 http://tw.archive.ubuntu.com/ubuntu/ lucid/universe libauthen-pam-perl 0.16-2 [34.2kB]
下載:3 http://tw.archive.ubuntu.com/ubuntu/ lucid/universe libnet-ssleay-perl 1.35-2ubuntu1 [209kB]
取得 359kB 用了 1s (289kB/s)
正在預先設定套件 …
(正在讀取資料庫 … 系統目前共安裝了 44125 個檔案和目錄。)
正準備替換 libpam-runtime 1.1.1-2ubuntu5.3(使用 …/libpam-runtime_1.1.1-2ubuntu5.4_all.deb)…
正在解開替換的套件檔 libpam-runtime …
正在進行 man-db 的觸發程式 …
正在設定 libpam-runtime (1.1.1-2ubuntu5.4) …

選取了原先未被選取的套件 libauthen-pam-perl。
(正在讀取資料庫 … 系統目前共安裝了 44125 個檔案和目錄。)
正在解開 libauthen-pam-perl (從 …/libauthen-pam-perl_0.16-2_amd64.deb)…
選取了原先未被選取的套件 libnet-ssleay-perl。
正在解開 libnet-ssleay-perl (從 …/libnet-ssleay-perl_1.35-2ubuntu1_amd64.deb)…
正在進行 man-db 的觸發程式 …
正在設定 libauthen-pam-perl (0.16-2) …
正在設定 libnet-ssleay-perl (1.35-2ubuntu1) …

root@www3:~# sudo apt-get -f install
正在讀取套件清單… 完成
正在重建相依關係
正在讀取狀態資料… 完成
升級 0 個,新安裝 0 個,移除 0 個,有 57 個未被升級。

2.下載webmin_1.570_all.deb
root@www3:~# wget http://prdownloads.sourceforge.net/webadmin/webmin_1.570_all.deb
–2011-12-15 12:21:45–  http://prdownloads.sourceforge.net/webadmin/webmin_1.570_all.deb
正在查找主機 prdownloads.sourceforge.net… 216.34.181.59
正在連接 prdownloads.sourceforge.net|216.34.181.59|:80… 連上了。
已送出 HTTP 要求,正在等候回應… 301 Moved Permanently
位置:http://downloads.sourceforge.net/project/webadmin/webmin/1.570/webmin_1.570_all.deb [跟隨連結]
–2011-12-15 12:21:49–  http://downloads.sourceforge.net/project/webadmin/webmin/1.570/webmin_1.570_all.deb
正在查找主機 downloads.sourceforge.net… 216.34.181.59
繼續使用和 prdownloads.sourceforge.net:80 的連線。
已送出 HTTP 要求,正在等候回應… 302 Found
位置:http://ncu.dl.sourceforge.net/project/webadmin/webmin/1.570/webmin_1.570_all.deb [跟隨連結]
–2011-12-15 12:21:51–  http://ncu.dl.sourceforge.net/project/webadmin/webmin/1.570/webmin_1.570_all.deb
正在查找主機 ncu.dl.sourceforge.net… 140.115.17.45
正在連接 ncu.dl.sourceforge.net|140.115.17.45|:80… 連上了。
已送出 HTTP 要求,正在等候回應… 200 OK
長度: 14884300 (14M) [application/octet-stream]
Saving to: `webmin_1.570_all.deb’

100%[=====================>] 14,884,300  3.16M/s   in 4.3s

2011-12-15 12:21:59 (3.33 MB/s) – `webmin_1.570_all.deb’ saved [14884300/14884300]

3.補安裝套件

root@www3:~# sudo apt-get install libio-pty-perl
正在讀取套件清單… 完成
正在重建相依關係
正在讀取狀態資料… 完成
您也許得執行 `apt-get -f install’ 以修正這些問題:
下列的套件有未滿足的相依關係:
webmin: 相依關係: apt-show-versions 但它卻將不會被安裝
E: 未能滿足相依關係。請試著不指定套件來執行 ‘apt-get -f install’(或採取其它的解決方案)。

root@www3:~# sudo apt-get install apt-show-versions

正在讀取套件清單… 完成

正在重建相依關係

正在讀取狀態資料… 完成

apt-show-versions 已經是最新版本了。

apt-show-versions 被設定為手動安裝。

升級 0 個,新安裝 0 個,移除 0 個,有 3 個未被升級。

4.安裝webmin

root@www3:~#  sudo dpkg -i webmin_1.570_all.deb

(正在讀取資料庫 … 系統目前共安裝了 63231 個檔案和目錄。)

正準備替換 webmin 1.570(使用 webmin_1.570_all.deb)…

正在解開替換的套件檔 webmin …

正在設定 webmin (1.570) …

Webmin install complete. You can now login to webmin

as root with your root password, or as any user who can use sudo

to run commands as root.

root@www3:~# sudo apt-get -f install

正在讀取套件清單… 完成
正在重建相依關係
正在讀取狀態資料… 完成
正在修正相依關係…
完成
下列的額外套件將被安裝:
apt-show-versions libapt-pkg-perl libio-pty-perl
下列【新】套件將會被安裝:
apt-show-versions libapt-pkg-perl libio-pty-perl
升級 0 個,新安裝 3 個,移除 0 個,有 57 個未被升級。
1 個沒有完整得安裝或移除。
需要下載 166kB 的套件檔。
此操作完成之後,會多佔用 676kB 的磁碟空間。
下載:1 http://tw.archive.ubuntu.com/ubuntu/ lucid/main libio-pty-perl 1:1.07-2build1 [42.4kB]
下載:2 http://tw.archive.ubuntu.com/ubuntu/ lucid/main libapt-pkg-perl 0.1.24 [90.1kB]
下載:3 http://tw.archive.ubuntu.com/ubuntu/ lucid/universe apt-show-versions 0.16 [33.7kB]
取得 166kB 用了 0s (173kB/s)
選取了原先未被選取的套件 libio-pty-perl。
(正在讀取資料庫 … 系統目前共安裝了 60699 個檔案和目錄。)
正在解開 libio-pty-perl (從 …/libio-pty-perl_1%3a1.07-2build1_amd64.deb)…
選取了原先未被選取的套件 libapt-pkg-perl。
正在解開 libapt-pkg-perl (從 …/libapt-pkg-perl_0.1.24_amd64.deb)…
選取了原先未被選取的套件 apt-show-versions。
正在解開 apt-show-versions (從 …/apt-show-versions_0.16_all.deb)…
正在進行 man-db 的觸發程式 …
正在設定 libio-pty-perl (1:1.07-2build1) …
正在設定 libapt-pkg-perl (0.1.24) …
正在設定 apt-show-versions (0.16) …
** initializing cache. This may take a while **

正在設定 webmin (1.570) …
Webmin install complete. You can now login to webmin

as root with your root password, or as any user who can use sudo
to run commands as root.

發表留言